Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
PEXA Email Issue
Incident Report for PEXA
Resolved
The previously reported issue impacting the delivery of emails from the PEXA Support Centre has now been resolved.

Thank you for your patience.
Posted Sep 14, 2020 - 17:57 AEST
Monitoring
The previously reported issue impacting the delivery of emails from the PEXA Support Centre has now been resolved.

Thank you for your patience.
Posted Sep 14, 2020 - 15:18 AEST
Identified
We are currently investigating an issue impacting the delivery of emails from the PEXA Support Centre.

As a result of this, emails from the address 'support@pexa.com.au' are not reaching their recipients.

An update will be provided shortly.
Posted Sep 14, 2020 - 14:27 AEST