Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Login Service Issue
Incident Report for PEXA
Resolved
The previously reported issue impacting some users when logging into PEXA is now resolved.
Posted Jul 27, 2020 - 18:55 AEST
Investigating
We are aware that some members are experiencing issues accessing the PEXA Exchange. We are urgently working to resolve this incident and will provide further updates as soon as they are available.
Posted Jul 27, 2020 - 18:12 AEST
This incident affected: Login & Multi-Factor Authentication Service.