Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Service Issue - WA
Incident Report for PEXA
Resolved
The previously reported issue impacting Stamp Duty Services in WA is now resolved.
Posted Jul 02, 2020 - 15:18 AEST
Identified
We are continuing to investigate an issue impacting Stamp Duty Services in WA.

As a result, Stamp Duty Verification may experience delays.
Posted Jul 02, 2020 - 14:02 AEST
Investigating
We are currently investigating an issue impacting Stamp Duty Services in WA.

As a result, Stamp Duty Verification may experience delays.
Posted Jul 02, 2020 - 13:02 AEST
This incident affected: Stamp Duty Services (WA).