Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Login Service Issue
Incident Report for PEXA
Resolved
The previously reported issue impacting some users when logging into PEXA is now resolved.
Posted Mar 31, 2020 - 13:04 AEDT
Monitoring
The previously reported issue impacting some users when logging into PEXA is now resolved.
Posted Mar 31, 2020 - 11:57 AEDT
Investigating
PEXA is aware of an issue impacting some users, who may receive an error when logging into PEXA Exchange.

If you encounter an error, please refresh your browser and try again.
Posted Mar 31, 2020 - 10:19 AEDT
This incident affected: Login & Multi-Factor Authentication Service.