Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Service Issue - QLD
Incident Report for PEXA
Resolved
This incident has been resolved.
Posted Apr 17, 2020 - 16:26 AEST
Investigating
We are currently investigating an issue impacting Stamp Duty Services in QLD.

As a result, Stamp Duty Verification may experience delays
Posted Apr 02, 2020 - 18:35 AEDT
This incident affected: Stamp Duty Services (QLD).