Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
TAS
Service Issue - Payment File Response
Incident Report for PEXA
Resolved
The issue impacting WA transactions has been resolved.

Impacted workspaces that had commenced settling will now proceed as scheduled.

We’re sorry for the inconvenience this has caused you and the buyers and sellers you represent.
Posted Jul 15, 2024 - 18:04 AEST
Investigating
We’re aware of an issue that’s impacting WA transactions.

If your workspace is affected and has commenced settling it will likely remain in a status of 'Lodging and Settling' for longer than usual until the issue is fixed.

We’re working to resolve this issue.

We thank you for your patience and we’re sorry for the inconvenience this has caused you and your clients.

We’ll provide you with an update within the hour.
Posted Jul 15, 2024 - 17:34 AEST
This incident affected: Financial Settlement Services.