Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
State-Specific Services
Service
VIC
NSW
QLD
WA
SA
Service Issue - VIC
Incident Report for PEXA
Resolved
The issue that was impacting services in Victoria is now resolved.

Workspace Creation, Lodgement and Lodgement Verification is now working as normal.

We apologise for any inconvenience caused to you and your clients.
Posted Nov 25, 2021 - 17:26 AEDT
Monitoring
The issue that was impacting services in Victoria is now resolved.

Workspace Creation, Lodgement and Lodgement Verification is now working as normal.

We apologise for any inconvenience caused to you and your clients.
Posted Nov 25, 2021 - 16:29 AEDT
Investigating
We are currently investigating an issue impacting services in Victoria.

This means that there may be delays with Lodgement and Lodgement Verification, as well as Workspace creation and Title Activity Checks.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Nov 25, 2021 - 15:37 AEDT
This incident affected: Workspace Creation, Document Preparation & Lodgement Services (Victoria).