Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Service Issue - WA
Incident Report for PEXA
Resolved
The previously reported issue impacting Transfer Duty Services in WA is now resolved.

Transfer Duty Verification services have now returned to normal.
Posted Jun 09, 2021 - 16:18 AEST
Monitoring
The previously reported issue impacting Transfer Duty Services in WA is now resolved.

Transfer Duty Verification services have now returned to normal.
Posted Jun 09, 2021 - 15:05 AEST
Investigating
We are currently investigating an issue impacting Transfer Duty Services in WA.

As a result, Transfer Duty Verification may experience delays.
Posted Jun 09, 2021 - 13:54 AEST
This incident affected: Stamp Duty Services (WA).