Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2024 - 08:00 AEDT
Scheduled
PEXA will be conducting a system maintenance on Saturday 9th November 2024 from 8:00pm – midnight AEDT.
Please note the following: • There is a low likelihood of some users being logged off. If this occurs, please simply log back in per normal. • Some users may experience slower response times. We kindly request your patience during the maintenance window. • Some features may not be available during the maintenance window. If this occurs, please retry after the conclusion of the release.
Posted Nov 07, 2024 - 14:17 AEDT
This scheduled maintenance affected: Workspace Creation, Document Preparation & Lodgement Services (VIC, NSW, QLD, WA, SA, ACT, TAS).