Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 01, 2024 - 08:00 AEST
Scheduled
PEXA will be conducting a system upgrade release on Saturday 1st June 2024 from 8:00am – midnight.
Please note the following: - There is a low likelihood of some users being logged off. If this occurs, please simply log back in per normal. - Some users may experience slower response times. We kindly request your patience during the release window. - Some features may not be available during the release window. If this occurs, please retry after the release window.
Posted May 31, 2024 - 13:33 AEST
This scheduled maintenance affected: Workspace Creation, Document Preparation & Lodgement Services (VIC, NSW, QLD, WA, SA, ACT).