Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Service Issue - QLD
Incident Report for PEXA
Resolved
The reported issue impacting services in Queensland is now resolved.

Lodgement and Lodgement Verification are now operating as normal.

We thank you for your patience.
Posted May 11, 2022 - 12:29 AEST
Update
We are continuing to closely monitor the situation.

We confirm that Lodgement and Lodgement Verification are working as normal.

We will provide you with an update in an hour.
Posted May 11, 2022 - 11:30 AEST
Update
We are continuing to closely monitor the situation.

We confirm that Lodgement and Lodgement Verification are working as normal.

We will provide you with an update in an hour.
Posted May 11, 2022 - 10:32 AEST
Monitoring
The issue that was impacting services in Queensland is now resolved and we will continue to closely monitor the situation.

Lodgement and Lodgement Verification are now working as normal.

We thank you for your patience and will provide you with an update in an hour.
Posted May 11, 2022 - 09:33 AEST
Update
PEXA and Titles Queensland are continuing to work to resolve the issue impacting lodgement and lodgement verification services.

We’re sorry for the inconvenience this is causing you and your clients.

We will provide a further update tomorrow morning.
Posted May 10, 2022 - 17:19 AEST
Update
We are continuing to investigate an issue impacting services in Queensland.

This means that there may be delays with Lodgement and Lodgement Verification.

We’re sorry for the inconvenience this is causing you and your clients.

We’ll provide you with an update within the hour.
Posted May 10, 2022 - 16:32 AEST
Update
We are continuing to investigate this issue.
Posted May 10, 2022 - 15:27 AEST
Investigating
We are currently investigating an issue impacting services in Queensland.

This means that there may be delays with Lodgement and Lodgement Verification.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted May 10, 2022 - 14:33 AEST
This incident affected: Workspace Creation, Document Preparation & Lodgement Services (QLD).