Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
TAS

Service Issue - Mobile Signing

Incident Report for PEXA

Resolved

This incident has now been resolved.
Posted Mar 12, 2025 - 15:38 AEDT

Identified

We are continuing to investigate an issue impacting mobile signing services.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Mar 12, 2025 - 14:33 AEDT

Update

We are currently investigating an issue impacting mobile signing services.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Mar 12, 2025 - 13:39 AEDT

Investigating

We are currently investigating an issue impacting mobile signing services.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Mar 12, 2025 - 13:32 AEDT
This incident affected: Mobile Signing Validation.