Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Service Issue - QLD
Incident Report for PEXA
Resolved
The reported issue impacting Transfer Duty in Queensland is now resolved.

Transfer Duty Verification is now operating as normal.

We apologise for any inconvenience caused to you and the buyers and sellers you represent and thank you for your patience.
Posted May 10, 2022 - 17:08 AEST
Monitoring
The issue that was impacting Transfer Duty in Queensland is now resolved.

Transfer Duty Verification is now working as normal.

We apologise for any inconvenience caused to you and your clients.

We thank you for your patience and will provide you with an update in an hour.
Posted May 10, 2022 - 16:15 AEST
Update
We are continuing to investigate this issue.
Posted May 10, 2022 - 15:27 AEST
Investigating
We are currently investigating an issue impacting Transfer Duty Services in Queensland.

This means that there may be delays with Stamp Duty Verification.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted May 10, 2022 - 14:54 AEST
This incident affected: Stamp Duty Services (QLD).