Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 26, 2024 - 08:00 AEDT
Scheduled
PEXA is planning a scheduled maintenance. From Saturday 26th Oct 8:00am to 2:00pm AEDT the PEXA Exchange, Plus, Planner, Projects will be temporarily unavailable.
We apologies for any inconvenience this may cause and appreciate your understanding.
If you have any questions, please contact our Support Team via support@pexa.com.au
Posted Oct 21, 2024 - 08:49 AEDT
This scheduled maintenance affected: Workspace Creation, Document Preparation & Lodgement Services (VIC, NSW, QLD, WA, SA, ACT, TAS), Stamp Duty Services (VIC, NSW, QLD, WA, SA, ACT, TAS), and Digital Signing Validation, Mobile Signing Validation, Financial Settlement Services, Login & Multi-Factor Authentication Service.