Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
TAS
Service Issue - QLD
Incident Report for PEXA
Resolved
The reported issue impacting Transfer Duty in Queensland is now resolved.

Transfer Duty Verification is now operating as normal.

We apologise for any inconvenience caused to you and the buyers and sellers you represent and thank you for your patience.
Posted Jun 28, 2024 - 08:19 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 27, 2024 - 17:06 AEST
Update
We are currently investigating an issue impacting Transfer Duty Services in Queensland.

This means that there may be delays with Stamp Duty Verification.


Thank you for your patience.
Posted Jun 27, 2024 - 16:04 AEST
Update
We are continuing to investigate this issue.
Posted Jun 27, 2024 - 15:15 AEST
Update
We are continuing to investigate this issue.
Posted Jun 27, 2024 - 14:15 AEST
Investigating
We are currently investigating an issue impacting Transfer Duty Services in Queensland.

This means that there may be delays with Stamp Duty Verification.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Jun 27, 2024 - 13:18 AEST
This incident affected: Stamp Duty Services (QLD).