Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 16, 2024 - 20:00 AEST
Scheduled
PEXA will be conducting a system maintenance release on Monday 16th of September from 8:00pm – 10:00pm
Please note the following:
There is a low likelihood of some users being logged off. If this occurs, please simply log back in per normal. We kindly request your patience during the deployment window.
Posted Sep 11, 2024 - 16:55 AEST
This scheduled maintenance affected: Login & Multi-Factor Authentication Service.