Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
WA Service Issue
Incident Report for PEXA
Resolved
The previously reported issue impacting Stamp Duty Services in WA is now resolved.

As a result, Stamp Duty Verification will proceed as normal.
Posted Dec 06, 2019 - 15:57 AEDT
Monitoring
The previously reported issue impacting Stamp Duty Services in WA is now resolved.

As a result, Stamp Duty Verification will proceed as normal.
Posted Dec 06, 2019 - 15:32 AEDT
Investigating
We are currently investigating an issue impacting Stamp Duty Services in WA.

As a result, Stamp Duty Verification may experience delays.
Posted Dec 06, 2019 - 14:46 AEDT
This incident affected: Stamp Duty Services (WA).