Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
PEXA Support Phone Connectivity Issue
Incident Report for PEXA
Resolved
Please be advised that the previous issue impacting members from reaching us via our Member Support Centre telephone line has been resolved and our systems are now operating as normal.

We recognise the inconvenience this has caused and we're very sorry for the disruption. Thank you for your patience today.
Posted Jul 26, 2022 - 14:01 AEST
Monitoring
Please be advised that the previous issue impacting our PEXA Support Phone line has been resolved.

We will continue to monitor for any further issues.

We’re sorry for the inconvenience this has caused you and the buyers and sellers you represent.
Posted Jul 26, 2022 - 13:01 AEST
Update
We are continuing to work through an issue preventing members from reaching us via our Member Support Centre telephone line.

We recognise the inconvenience this causes and we're very sorry for the disruption.

Please direct all urgent enquiries to support@pexa.com.au where our team will be able to assist.

We will continue to provide updates on the hour until a resolution is found, or sooner. Thank you for your patience.
Posted Jul 26, 2022 - 12:08 AEST
Update
We are continuing to investigate an issue with our Support Centre phone line service provider, that is preventing members from reaching us via telephone.

For all urgent enquiries, please email support@pexa.com.au.

We are working with our provider to resolve this matter urgently and will advise you of a resolution as soon as possible.
Posted Jul 26, 2022 - 11:13 AEST
Update
We are continuing to investigate an issue with our Support Centre phone line service provider, that is preventing members from reaching us via telephone.

For all urgent enquiries, please email support@pexa.com.au.

We are working with our provider to resolve this matter urgently and will advise you of a resolution as soon as possible.

We apologise for any inconvenience this may cause this morning
Posted Jul 26, 2022 - 10:08 AEST
Investigating
We are currently investigating an issue with our Support Centre phone line service provider, that is preventing members from reaching us via telephone.

For all urgent enquiries, please email support@pexa.com.au.

We are working with our provider to resolve this matter urgently and will advise you of a resolution as soon as possible.

We apologise for any inconvenience this may cause this morning
Posted Jul 26, 2022 - 09:02 AEST
This incident affected: Workspace Creation, Document Preparation & Lodgement Services (VIC, NSW, QLD, WA, SA, ACT).