Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 29, 2023 - 23:00 AEDT
Scheduled
PEXA will be conducting system maintenance on Wednesday 29th November from 11:00pm to 1am AEDT. Please note the following: Some users may experience slower response times. We kindly request your patience during the deployment window. Some features may not be available during the deployment window. If this occurs, please retry after the conclusion of the release.
Posted Nov 29, 2023 - 20:36 AEDT
This scheduled maintenance affected: Workspace Creation, Document Preparation & Lodgement Services (VIC, NSW, QLD, WA, SA, ACT).