Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 11, 2025 - 21:00 AEST
Scheduled
PEXA will be conducting a system maintenance on Friday, April 11th, 2025, around 9PM – 10PM AEST.
Please note the following:
• There is a low likelihood of some users being logged off. If this occurs, please simply log back in per normal. • Some users may experience slower response times. We kindly request your patience during the deployment window. • Some features may not be available during the deployment window. If this occurs, please retry after the conclusion of the release.
Posted Apr 10, 2025 - 15:29 AEST
This scheduled maintenance affected: Login & Multi-Factor Authentication Service.