Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
TAS
Service Issue - WA
Incident Report for PEXA
Resolved
This incident has been resolved.
Posted Jul 01, 2024 - 14:23 AEST
Investigating
We are currently investigating an issue impacting Transfer Duty Services in Western Australia.

This means that there may be delays with Transfer Duty Verification.

We’ll provide you with an update within the hour.

Thank you for your patience.
Posted Jul 01, 2024 - 13:41 AEST
This incident affected: Stamp Duty Services (WA).