Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Jurisdiction-Specific
Service
VIC
NSW
QLD
WA
SA
ACT
Service Issue - NSW
Incident Report for PEXA
Resolved
This incident has been resolved.
Posted Apr 06, 2021 - 15:06 AEST
Investigating
We are currently investigating an issue impacting Stamp Duty Services in NSW.

As a result, Stamp Duty Verification may experience delays.
Posted Apr 06, 2021 - 14:04 AEST
This incident affected: Stamp Duty Services (NSW).