Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
State-Specific Services
Service
VIC
NSW
QLD
WA
SA
Service Issue - QLD
Incident Report for PEXA
Resolved
The previously reported issue impacting Stamp Duty Services in QLD is now resolved.

Stamp Duty Verification services have now returned to normal.
Posted Apr 06, 2021 - 18:41 AEST
Monitoring
The previously reported issue impacting Stamp Duty Services in QLD is now resolved.

Stamp Duty Verification services have now returned to normal.
Posted Apr 06, 2021 - 16:19 AEST
Update
We are continuing to investigate an issue impacting Stamp Duty Services in QLD.

As a result, Stamp Duty Verification may experience delays.
Posted Apr 06, 2021 - 15:14 AEST
Update
We are continuing to investigate an issue impacting Stamp Duty Services in QLD.

As a result, Stamp Duty Verification may experience delays.
Posted Apr 06, 2021 - 14:03 AEST
Identified
We are continuing to investigate an issue impacting Stamp Duty Services in QLD.

As a result, Stamp Duty Verification may experience delays.
Posted Apr 06, 2021 - 12:51 AEST
Investigating
We are currently investigating an issue impacting Stamp Duty Services in QLD.

As a result, Stamp Duty Verification may experience delays
Posted Apr 06, 2021 - 11:41 AEST
This incident affected: Stamp Duty Services (QLD).